Export to .DOCX doesn't preserve frormatting

Atanas's Avatar

Atanas

19 Nov, 2017 11:42 AM

Working in Scrivener, output to .docx. Issues included, repeating all text after a superscript or subscript, unordered list format, and
Doesn't seem to be too much of an issue in .PDF, and not as bad, but problem still occurs in .DOC.

What could be causing this?

  1. Support Staff 1 Posted by Brett on 20 Nov, 2017 05:40 PM

    Brett's Avatar

    DOCX export is currently very primitive. The entire RTF system is
    undergoing a rewrite, hope to have that ready soon.

    -Brett

  2. 2 Posted by Atanas on 29 Nov, 2017 12:03 AM

    Atanas's Avatar

    Okay, thanks for the reply. I have been trying to use a custom template as per pandoc documentation guide. And it picks up everything except the reference list when run in terminal, but doesn't seem to work when I put the same arguments (minus the specified document names) in the custom processor. When I do this, the custom processor light turns red. Can you please help / provide any advice? See below for what I am using.

    Terminal syntax:
    $ pandoc ref1.markdown -r markdown+smart --data-dir=/Users/atanasjanackovski/.pandoc/templates -t docx -s --filter pandoc-citeproc --bibliography /Users/atanasjanackovski/Dropbox/Uni/PhD/#Zotero/MyLib.bib --csl /Users/atanasjanackovski/Zotero/styles/apa-old-doi-prefix.csl -o ref1c.docx

    Marked custom processor:

    Similar arguments to above which produce the error:
    -r markdown+smart --data-dir=/Users/atanasjanackovski/.pandoc/templates -t docx -s --filter pandoc-citeproc --bibliography /Users/atanasjanackovski/Dropbox/Uni/PhD/#Zotero/MyLib.bib --csl /Users/atanasjanackovski/Zotero/styles/apa-old-doi-prefix.csl

    I've also tried to point to a data directory as per pandoc guide:
    -f markdown --data-dir=/Users/atanasjanackovski/.pandoc/templates -t html5 -s --bibliography /Users/atanasjanackovski/Dropbox/Uni/PhD/#Zotero/MyLib.bib --csl /Users/atanasjanackovski/Zotero/styles/apa-old-doi-prefix.csl

    to no avail. And finally, i tried this:
    -f markdown --data-dir=/Users/atanasjanackovski/.pandoc/templates -t docx -s --bibliography /Users/atanasjanackovski/Dropbox/Uni/PhD/#Zotero/MyLib.bib --csl /Users/atanasjanackovski/Zotero/styles/apa-old-doi-prefix.csl

    But the last one created an error too.

    The terminal command seems to work, however, the bibliography is not formatted as a bibliography - not sure if this is the css file or not. Can you pleas share some wisdom?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac