YAML metadata doesn't remains invisible in the rendering

Marek Kowalczyk's Avatar

Marek Kowalczyk

27 Sep, 2017 11:09 AM

Hi, this is my metadata block, which is at the very top of the file:

title: Cancer history in patients with acute coronary syndrome is associated with less frequent achievement of TIMI flow 3
author: Anna Skrobisz et al.
date: 2017-09-27
Base Header Level: 2
...

Neither /usr/local/bin/pandoc -f markdown -t html5 --smart --normalize --standalone nor the standard processor consistently create a visible title/author date section at the top of the document. I.e., from time to time I was able to obtain a rendition. But its appearance seems random to me and I couldn't replicate it.

Version 2.5.10 (930)

  1. Support Staff 1 Posted by Brett on 27 Sep, 2017 08:21 PM

    Brett's Avatar

    Marked and MultiMarkdown have no built-in features for generating a
    title block from YAML. Pandoc may, but running your command on the
    command line with the YAML block provided never gave me a title page.

    If you set Marked to "Treat YAML as MMD metadata" under
    Preferences>Advanced, you could then use a MultiMarkdown placeholder (if
    you're using the built in MMD):

    # [%title]

    *[%author]

    I'm uncertain exactly what you're looking for, though.

    -Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac