Nothing happens . . .

's Avatar


23 Sep, 2011 02:40 PM

I imagine I must be doing something wrong. I start a new TextEdit document (tried it in Bean, too), save the document so I have a name, and then drag the icon from the document toolbar onto the Marked icon in my dock. Nothing happens. The options in the Preview menu, and most of the other menu items, are greyed out. I have no idea what I'm doing wrong. Any help would be appreciated.


  1. Support Staff 1 Posted by Brett on 23 Sep, 2011 02:51 PM

    Brett's Avatar

    Hi Evan,

    What extension are you using on your files?

    Could you check the system.log in at the time you drop a file on Marked to see if there are errors reported?

  2. 2 Posted by Evan on 23 Sep, 2011 03:04 PM

    Evan's Avatar

    Thanks for the quick reply, Brett. The TextEdit file is an rtf file. The Bean file is rtfd.

    The copy of my console log for around the time I drag a file onto Marked is below. Perhaps this is something dumb on my part- does Marked required anything aside from installing the app itself? I know that other apps require Markdown to be installed on the machine, and copied to a particular place. Is that required with Marked? Thank you.

    9/23/11 10:57:50.441 AM (com.swarmcast.mlbnexdefautobahn[21331]) Bug: launchd_core_logic.c:4692 (24984):13
    9/23/11 10:58:00.444 AM (com.swarmcast.mlbnexdefautobahn[21332]) Bug: launchd_core_logic.c:4692 (24984):13
    9/23/11 10:58:10.449 AM (com.swarmcast.mlbnexdefautobahn[21336]) Bug: launchd_core_logic.c:4692 (24984):13
    9/23/11 10:58:19.403 AM firefox-bin kCGErrorIllegalArgument: CGSGetWindowLevel
    9/23/11 10:58:19.404 AM firefox-bin kCGErrorIllegalArgument: CGSGetWindowAlpha
    9/23/11 10:58:19.404 AM firefox-bin kCGErrorIllegalArgument: CGSGetScreenRectForWindow
    9/23/11 10:58:20.453 AM (com.swarmcast.mlbnexdefautobahn[21338]) Bug: launchd_core_logic.c:4692 (24984):13
    9/23/11 10:58:30.458 AM (com.swarmcast.mlbnexdefautobahn[21339]) Bug: launchd_core_logic.c:4692 (24984):13

  3. 3 Posted by Evan on 23 Sep, 2011 03:08 PM

    Evan's Avatar

    I figured this out. I didn't even realize there was an option to disable RTF mode in TextEdit. I'm using normal text now, and it seems to work. I take it this (or Markdown) only works with plain text?

  4. Support Staff 4 Posted by Brett on 23 Sep, 2011 03:09 PM

    Brett's Avatar

    That's your issue. Marked works with Plain Text (txt, md, mmd, etc.) only. Convert to plain text mode in TextEdit (and I think you can do it in Bean) and save with a .txt or .md extension and then try again. Note that things like Bold, Italics and images placed in your RTF files will disappear, but Marked is designed to work with Markdown.

  5. Support Staff 5 Posted by Brett on 23 Sep, 2011 03:10 PM

    Brett's Avatar

    Just replied before I got this, but yes, Markdown is a plain-text system.

  6. 6 Posted by Evan on 23 Sep, 2011 03:12 PM

    Evan's Avatar

    Thanks for you help. I figured it was something dumb on my end.

  7. Brett closed this discussion on 23 Sep, 2011 03:16 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac