Preview Problem

Mario Suharja's Avatar

Mario Suharja

31 May, 2017 09:11 AM

// Please enter a detailed description of the issue
// Description of the issue:

Why some of the code inside codeblock previewed as bold when it should not be bold?
Please take a look at the attached screenshot.

// Please enter a list of steps required to reproduce the issue
// Steps to reproduce:

1. Just preview attached markdown document from Bear 1.2 (4715)
2.
3.

// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit)
Marked 2 930 (Direct)
OS X Version: 10.12.5
---
additionalMathJaxConfig:
allowPageBreakInCode: 1
bookTxtIsLeanpub: 0
summaryMdIsGitBook: 0
codeIsPoetry: 0
collapsibleHeadlines: 0
convertGithubCheckboxes: 1
convertYAMLToMMD: 0
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 0
defaultProcessor: MultiMarkdown
enableMiniMap: 0
excludeBlockQuotesFromCounts: 0
excludeFootnotesFromCounts: 0
excludeVerbatimFromCounts: 0
excludeCaptionsFromCounts: 0
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: 1
h1IsPageBreak: 0
h2IsPageBreak: 0
hrIsPageBreak: 0
includeMathJax: 0
limitTextWidth: 0
minimalJavaScript: 0
outlineModeExtensions:
permissionGranted: 0
printHeaderBottomLeft:
printHeaderBottomRight:
printHeaderFooterFirstPage: 0
printHeaderTopLeft:
printHeaderTopRight:
processHTMLFiles: 1
removeMetadataForPreview: 0
removeYAMLHeaders: 0
scrollToEdit: 1
shouldDetectCritic: 1
shouldHighlightMarkupErrors: 0
shouldLoadCritic: 0
syntaxHighlight: 1

  1. Support Staff 1 Posted by Brett on 31 May, 2017 05:43 PM

    Brett's Avatar

    Hi Mario,

    It's because you have syntax highlighting enabled. Because the code
    blocks are so short, it's taking a wild stab at what language they
    represent, and highlighting them based on its best guess. You can either
    turn off syntax highlighting in Preferences->Style, or define the
    language manually by using the syntax:

         ```bash
         bzip2 backup_db.sql
         ```

    -Brett

  2. 2 Posted by Mario Suharja on 01 Jun, 2017 02:48 PM

    Mario Suharja's Avatar

    Hi Brett,

    I see, thank you very much for your help.

  3. Brett closed this discussion on 06 Jun, 2017 02:56 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac