Open problems under 10.12.3 (16D32)

Andy Frank's Avatar

Andy Frank

26 Jan, 2017 04:33 PM

After updating to 10.12.3 - two different problems with open:

1. In app File > Open menu seems to silently crash
2. Using Finder "Open With" works - but opens two copies of doc

  1. Support Staff 1 Posted by Brett on 26 Jan, 2017 08:19 PM

    Brett's Avatar

    I'm running 10.12.3 and not seeing this behavior in either case. I have,
    however, had one other report of the double-open behavior. I am, at this
    point, not even sure what questions to ask to track the bug down. Any
    other info you can offer that might be relevant?

    -Brett

  2. 2 Posted by Andy Frank on 26 Jan, 2017 08:46 PM

    Andy Frank's Avatar

    Its quite odd - I’m not really sure where to look either - but it was
    working before I upgraded AFAIK.

    The double open only seems to occur when my “foo.md” text file is on my
    Desktop. Opening with Finder from another directory correctly opens a
    single copy.

    File > Open menu always seems to crash regardless of file location.

    I tried to remove and re-install - but same behavior.

  3. Support Staff 3 Posted by Brett on 26 Jan, 2017 08:47 PM

    Brett's Avatar

    could you open Help->Report an issue and copy the config rundown it
    provides into this thread?

  4. 4 Posted by Andy Frank on 26 Jan, 2017 08:50 PM

    Andy Frank's Avatar

    Sure:

    // Please enter a detailed description of the issue
    // Description of the issue:

    // Please enter a list of steps required to reproduce the issue
    // Steps to reproduce:

    1.
    2.
    3.

    // If applicable please attach a sample document that causes the issue for
    you.

    // Configuration (do not edit)
    Marked 2 925 (Mac App Store)
    OS X Version: 10.12.3
    ---
    additionalMathJaxConfig:
    allowPageBreakInCode: 1
    bookTxtIsLeanpub: 0
    codeIsPoetry: 0
    collapsibleHeadlines: 0
    convertGithubCheckboxes: 1
    convertYAMLToMMD: 0
    defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
    defaultPreviewStyle: 0
    defaultProcessor: MultiMarkdown
    enableMiniMap: 0
    excludeBlockQuotesFromCounts: 0
    excludeFootnotesFromCounts: 0
    excludeVerbatimFromCounts: 0
    excludeCaptionsFromCounts: 0
    folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
    githubNewlines: 0
    h1IsPageBreak: 0
    h2IsPageBreak: 0
    hrIsPageBreak: 0
    includeMathJax: 0
    limitTextWidth: 0
    minimalJavaScript: 0
    outlineModeExtensions:
    permissionGranted: 0
    printHeaderBottomLeft:
    printHeaderBottomRight:
    printHeaderFooterFirstPage: 0
    printHeaderTopLeft:
    printHeaderTopRight:
    processHTMLFiles: 1
    removeMetadataForPreview: 0
    removeYAMLHeaders: 0
    scrollToEdit: 1
    shouldDetectCritic: 1
    shouldHighlightMarkupErrors: 0
    shouldLoadCritic: 0
    syntaxHighlight: 1

  5. Support Staff 5 Posted by Brett on 26 Jan, 2017 09:08 PM

    Brett's Avatar

    Replicated your setup and am still not seeing any issue. Would it be
    possible to have you delete your preferences and see if it makes a
    difference? They'd be located in
    ~/Library/Containers/com.brettterpstra.marked2/Data/Library/Preferences/com.brettterpstra.marked2.plist,
    and you can back them up by moving the file to your Desktop (or anywhere
    else) if you'd like. Be sure to quit Marked first, and then to ensure
    the cache clears, reboot before starting Marked back up. If you can do
    that, let me know if it helps.

    -Brett

  6. 6 Posted by Andy Frank on 27 Jan, 2017 02:55 AM

    Andy Frank's Avatar

    That seemed todo the trick!

    Thanks for your help!!!

  7. Support Staff 7 Posted by Brett on 27 Jan, 2017 05:41 PM

    Brett's Avatar

    Excellent, sorry for the trouble.

  8. Brett closed this discussion on 27 Jan, 2017 05:41 PM.

  9. Brett re-opened this discussion on 02 Nov, 2017 11:10 PM

  10. Support Staff 8 Posted by Brett on 02 Nov, 2017 11:10 PM

    Brett's Avatar

    For anyone else visiting this topic, a solution was offered in this repeat of the same issue. The user apparently was able to fix the issue by executing (in Terminal):

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -seed

    I'd be curious if anyone else trying this could verify.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac