unable to open/preview documents

A. Cheng's Avatar

A. Cheng

21 Sep, 2011 03:10 PM

I just bought Marked from the AppStore. Each time I open the document from the FIle menu or dragging the icon to the Marked icon on the Dock, nothing happens. I don't see a preview or an error message. Also, when I try to open the Quick Overview files that comes with the app, through the Help menu, nothing happens.

  1. Support Staff 1 Posted by Brett on 21 Sep, 2011 03:24 PM

    Brett's Avatar

    I'm having a temporary Internet outage, but will work with you to debug as soon as possible. I apologize for the delay!

    -Brett (on iPhone)

  2. Support Staff 2 Posted by Brett on 21 Sep, 2011 08:42 PM

    Brett's Avatar

    Ok, I'm back online :). What extension(s) are on the files you're trying to open with Marked?

  3. 3 Posted by Amy on 21 Sep, 2011 09:55 PM

    Amy's Avatar

    I tried to open .txt files created using TextMate. Then I also tried a
    .mmd(?), also created with TextMate. I created another .txt file in
    WriteRoom to open with Marked, but no luck there either.

  4. Support Staff 4 Posted by Brett on 21 Sep, 2011 09:58 PM

    Brett's Avatar

    Are you on Snow Leopard or Lion?

    Could you take a look under system.log in the Console application (Applications/Utilities/Console.app) at the time you drop a file on the Marked icon and tell me if you see any errors come up related to Marked?

  5. 5 Posted by Amy on 21 Sep, 2011 10:02 PM

    Amy's Avatar

    I'm on Snow Lion. Here's the output:

    Sep 21 18:00:04 Marked[1781]: launch path not accessible
    Sep 21 18:00:04 Marked[1781]: An exception was thrown during execution of
    an NSScriptCommand...
    Sep 21 18:00:04 Marked[1781]: launch path not accessible

  6. Support Staff 6 Posted by Brett on 21 Sep, 2011 11:21 PM

    Brett's Avatar

    Do you have a current installation of MultiMarkdown at /usr/local/bin/multimarkdown?

  7. 7 Posted by Amy on 22 Sep, 2011 02:32 PM

    Amy's Avatar

    It was missing but I just installed it. It's still throwing a similar error
    (though it opened the Overview file just fine):

    Marked[172]: launch path not accessible
    Marked[172]: An exception was thrown during execution of an
    NSScriptCommand...
    Marked[172]: launch path not accessible

  8. Support Staff 8 Posted by Brett on 22 Sep, 2011 02:44 PM

    Brett's Avatar

    No, I was hoping their _wasn't_ one at that location. Marked is looking for something and it seems to be finding the wrong thing, which is usually an incompatible version of MultiMarkdown on the disk. You don't have a custom processor defined at all, do you?

    If what you installed put a folder at /usr/local/bin/multimarkdown, then that's part of the problem, but the current version of Marked shouldn't be looking there anyway, as MultiMarkdown 3 is now embedded…

    Do you know of anything strange about your Ruby install, and do you have the option to strip MMD3 metadata turned on in Preferences?

  9. 9 Posted by Amy on 22 Sep, 2011 03:04 PM

    Amy's Avatar

    I had MMD3 turned on (tried loading a file with this setting turned on and
    off)

    I was having issues with Ruby a week ago. Gems would point to the incorrect
    directory and throw errors. I had to manually change the directories the
    Gems would point to.

  10. Support Staff 10 Posted by Brett on 22 Sep, 2011 03:54 PM

    Brett's Avatar

    Do you have a ruby binary at /usr/bin/ruby? It uses that one to run a couple of scripts right now. If that's failing, it might be the culprit.

  11. 11 Posted by Amy on 22 Sep, 2011 05:24 PM

    Amy's Avatar

    that directory doesn't exist. apparently my Ruby install was all tangled up
    but that's fixed now and Marked worked.

    thanks for all your help!

  12. Support Staff 12 Posted by Brett on 22 Sep, 2011 05:26 PM

    Brett's Avatar

    Glad to hear it!

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac