Bad font rendering

Erio's Avatar


21 Jan, 2016 09:04 PM

// Please enter a detailed description of the issue
// Description of the issue:
Rendering of the system runic font (accessed via Ctrl-Cmd-Space in the markdown text editor) is not done an the squared question mark is displayed. While rendering of the maths symbols is OK

On the attached screen shot: left, Marked2, right, Byword

// Please enter a list of steps required to reproduce the issue
// Steps to reproduce:


// If applicable please attach a sample document that causes the issue for you.

// Configuration (do not edit)
Marked 2 910 (Direct)
OS X Version: 10.11.3
allowPageBreakInCode: 1
bookTxtIsLeanpub: 0
codeIsPoetry: 0
collapsibleHeadlines: 0
convertGithubCheckboxes: 1
convertYAMLToMMD: 0
defaultMathJaxConfig: TeX-AMS-MML_HTMLorMML
defaultPreviewStyle: 6
defaultProcessor: MultiMarkdown
enableMiniMap: 0
excludeBlockQuotesFromCounts: 0
excludeFootnotesFromCounts: 0
excludeVerbatimFromCounts: 0
excludeCaptionsFromCounts: 0
folderPreviewExtensionsArray: md, markdown, txt, mdown, html, opml
githubNewlines: 1
h1IsPageBreak: 0
h2IsPageBreak: 0
hrIsPageBreak: 0
includeMathJax: 0
limitTextWidth: 0
minimalJavaScript: 0
permissionGranted: 0
printHeaderBottomLeft: %title, %date %time
printHeaderBottomRight: %page / %total
printHeaderFooterFirstPage: 1
processHTMLFiles: 1
removeMetadataForPreview: 0
removeYAMLHeaders: 0
scrollToEdit: 1
shouldDetectCritic: 1
shouldHighlightMarkupErrors: 0
shouldLoadCritic: 0
syntaxHighlight: 1

  1. Support Staff 1 Posted by Brett on 21 Jan, 2016 09:13 PM

    Brett's Avatar

    Only characters that the display font includes can be rendered. Very few available fonts contain a runic set, but if you have one, a custom theme or override style can be used instead.



  2. 2 Posted by Erio Barale-Tho... on 21 Jan, 2016 09:22 PM

    Erio Barale-Thomas's Avatar

    Thanks for the quick answer. Don't agree: I speak of the normal font which have all unocode character, incl math, runic, of ham, goth issue, dingbats. Open the emoji and symbols in Edit.

    Rgds / Cdlt / Mvg
    Erio (iPhone)

  3. Support Staff 3 Posted by Brett on 21 Jan, 2016 09:49 PM

    Brett's Avatar

    I'm not seeing the issue on my end:

    Is it possible your document is being saved with a non-UTF encoding?

  4. 4 Posted by Erio Barale-Tho... on 21 Jan, 2016 10:28 PM

    Erio Barale-Thomas's Avatar

    Well that's fun: I've the issue on my iMac but not on my MacBook Pro. The files are saved via iCloud so perfectly similar. So it must be some strange setting in my iMac: not in Marked pref because I checked. So your not guilty ;)

    But how to figure out what happens will take me long I'm afraid…

    Rgds / Cdlt / Mvg
    Erio (iPhone)

  5. Support Staff 5 Posted by Brett on 21 Jan, 2016 11:22 PM

    Brett's Avatar

    Does the issue occur in all themes, including Swiss?



Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Already uploaded files

  • Capture_d’écran_2016-01-21_à_21-22.01.32.png 311 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac