Custom preprocessor is not executable

's Avatar


26 Dec, 2015 08:39 PM

Since the latest version I get "Custom preprocessor is not executable". I have pandoc as the preprocessor and I chose /usr/local/bin/pandoc. This is executable from the shell. Although it is a symlink to the actual executable, even if I put the absolute path of the actual executable it doesn't work. And it has a+x as the right. Everything looks fine. I even tried to reinstall pandoc after deleting everything in Library/Containers/com.brettterpstra.marked2/ - still no luck.

  1. Support Staff 1 Posted by Brett on 26 Dec, 2015 09:05 PM

    Brett's Avatar

    This is an issue with SIP (System Integrity Protection) in OS X El Capitan. The direct version does not have this issue, and I'm happy to cross-grade you for free if you would like.

  2. 2 Posted by Philipp Keller on 26 Dec, 2015 10:29 PM

    Philipp Keller's Avatar

    aha, you mean crossgrading from the "App Store" version to a directly downloaded version? If that's correct then: yes, please!

  3. Support Staff 3 Posted by Brett on 26 Dec, 2015 11:56 PM

    Brett's Avatar

    License has been sent to the email registered here. Thanks!


  4. 4 Posted by Dave Smith on 03 Jan, 2016 03:34 PM

    Dave Smith's Avatar

    Hi Brett,
    I'm also experiencing the "custom processor not executable" error while using pandoc. Is there any chance of a cross-grade to the direct version as well please?


  5. 5 Posted by Jon Frisby on 05 Jan, 2016 05:43 AM

    Jon Frisby's Avatar

    Same issue for me. Please cross-grade me.

  6. 6 Posted by hagstrom on 12 Jan, 2016 11:41 PM

    hagstrom's Avatar

    Same here, I'd like to try it out for Textile but opted for MAS version not anticiptating there would be a difference.

  7. Support Staff 7 Posted by Brett on 12 Jan, 2016 11:57 PM

    Brett's Avatar

    I didn't get an email address with your post @hagstrom. Please contact me through and I'll provide the crossgrade.



  8. 8 Posted by Tomi on 02 Feb, 2016 07:34 AM

    Tomi's Avatar

    Dear Brett,
    I have The same issue with using pandoc as a custom processor. If possible, I would also like to obtain a non-mas licence. Thank you.

  9. 9 Posted by Philipp Keller on 02 Feb, 2016 07:54 AM

    Philipp Keller's Avatar

    No content.

  10. 10 Posted by hagstrom on 02 Feb, 2016 08:02 AM

    hagstrom's Avatar

    Since I got a notification on this thread, I'll just post a note to follow up on what happened for me. As was suggested to me via support on Twitter, for redcloth at least (which can be executed through ruby as well as directly), setting the processor to /usr/bin/ruby and setting the arguments to be the path to redcloth worked even with SIP in place and using the MAS version. (Since, I guess, /usr/bin/ruby is valid to execute even if SIP blocks arbitrary other binaries.) This workaround got me going right away without needing to move from the MAS version. But I think it will rely on the (pre)processor being able to be executed via a "safe" binary like redcloth is executable via /usr/bin/ruby. So, something like this might work depending on the specific (pre)processor one is trying to use.

  11. Support Staff 11 Posted by Brett on 02 Feb, 2016 02:47 PM

    Brett's Avatar

    Unfortunately the workaround doesn't work for processors distributed as
    binaries (as opposed to Ruby/Python executables). Pandoc and
    multimarkdown for example… these do require the switch to the direct

  12. 12 Posted by david on 05 Feb, 2016 01:31 AM

    david's Avatar

    I too am having this same issue.

  13. 13 Posted by Philipp Keller on 05 Feb, 2016 05:29 AM

    Philipp Keller's Avatar

    No content.

  14. 14 Posted by Spencer Lyon on 09 Feb, 2016 03:54 PM

    Spencer Lyon's Avatar

    Also having this issue with pandoc.

    Can I get a cross-grade license? Thank you

  15. 15 Posted by jan on 02 Mar, 2016 04:08 PM

    jan's Avatar

    Hello, I'd like to use pandoc as well, could I get the cross-grade licence? Thanks.

  16. Support Staff 16 Posted by Brett on 02 Mar, 2016 04:25 PM

    Brett's Avatar

    Due to complications with responding to crossgrade requests via this forum, if you're an MAS user wishing to switch to the direct version, please contact me directly through the form at

  17. Brett closed this discussion on 02 Mar, 2016 04:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac