Line Breaks from Ulysses for Mac not working

Dennis's Avatar

Dennis

01 Jun, 2015 03:55 PM

Hi,
I'm trying to use an unordered list in which each list item has multiple paragraphs. To add breaks in between paragraphs I'm using a "double space". Ulysses previews this correctly but when I bring the .md file into Marked 2 (demo) the source ends up looking like this -

<p>Here is an example of a list with multiple paragraphs:<br/>
- This is my first paragraph of typing. We will see if I can then add another one. This is my first paragraph of typing. We will see if I can then add another one. This is my first paragraph of typing. We will see if I can then add another one. This is my first paragraph of typing. We will see if I can then add another one. </p>

<pre><code>This is the second line for the first list item. This is the second line for the first list item. This is the second line for the first list item. This is the second line for the first list item. This is the second line for the first list item. This is the second line for the first list item.
</code></pre>

<ul>

I'm not sure why Marked is turning the second paragraph (set up by double space at end of first paragraph line) into "<pre><code>"?

Any thoughts?

Thanks.
<li>This is the next bulleted item. Hopefully we can see if this looks right.</li>
</ul>

  1. 1 Posted by Dennis on 01 Jun, 2015 04:58 PM

    Dennis's Avatar

    After a little more experimenting I found a work around. Instead of relying on the "-" to create the unordered list I escaped it in Ulysses. So, I would type something like this:

    \- This is what I want to be my first paragraph in my first list item. This is what I want to be my first paragraph in my first list item. This is what I want to be my first paragraph in my first list item.

    This is what I want to be my second paragraph in my first list item. This is what I want to be my second paragraph in my first list item.This is what I want to be my second paragraph in my first list item.

    \- This is what I want to be my first paragraph in my SECOND list item. This is what I want to be my first paragraph in my SECOND list item. This is what I want to be my first paragraph in my SECOND list item. This is what I want to be my first paragraph in my SECOND list item.

    Two things to keep in mind, In between paragraphs a normal "return" on the keyboard will make the single blank line break. The "\" is the escape character.

    Using this approach, the preview in Ulysses looks they way I'd like, AND also when opening the file in Marked 2 it looks exactly the same.

    Hope this helps someone else.

  2. Support Staff 2 Posted by Brett on 01 Jun, 2015 05:23 PM

    Brett's Avatar

    Can you show me a screenshot of your markdown in Ulysses without the escaping?

    It's quite likely that the blank line is causing Ulysses to export it's own forced line break, which then causes a list to end, thus the next indented paragraph is viewed as a code block (indented 4 spaces or 1 tab).

    Also check and see if you have "retain line breaks in paragraphs" enabled under Processor settings, and try toggling it to see if it makes a difference.

    It's a pain to have to escape your Markdown, so I'd prefer to find a solution that was more automatic. Ulysses does some odd things to the preview Markdown when it's converted, so I may have to compensate.

  3. 3 Posted by D S on 01 Jun, 2015 05:34 PM

    D S's Avatar

    Hi Brett,
    Here is the screenshot -
    [image: Inline image 1]

    To make the second paragraph in the list I pressed "shift+enter".

    Hope this helps..

    -Dennis

  4. Support Staff 4 Posted by Brett on 01 Jun, 2015 05:41 PM

    Brett's Avatar

    I'm not getting those results at all:

    Which processor are you using? And did you toggle the preserve paragraphs setting?

    The output from Ulysses Quick Preview appears to be properly adding the line break and indent to signify a paragraph. Are you inserting any manual tabs in the second paragraph? Also, which versions of Ulysses and Marked are you using?

  5. 5 Posted by D S on 01 Jun, 2015 07:26 PM

    D S's Avatar

    Hi Brett,
    Thank you very much for spending time on this. I think this must be a
    problem with Ulysses. Here is a screenshot of the Ulysses .md file as it
    comes into sublime text editor: [image: Inline image 1]

    You can see that the actual md file from ulysses is wrong. It put a tab in
    front of that second paragraph that does not exist in Ulysses itself when
    I'm looking at the doc. So I think Marked is working fine and the problem
    is with Ulysses.

    The version of Ulysses I'm using is the trial. I'd like to buy the full
    version if I knew it would fix the problem, but I'm not sure it will.

    Thanks,
    Dennis

  6. Support Staff 6 Posted by Brett on 01 Jun, 2015 07:53 PM

    Brett's Avatar

    No, that's actually correct. Within a list item, you have to indent an
    enclosed paragraph one time (4 spaces or a tab) for it to be included in
    that item. Otherwise it ends the list and begins a paragraph outside of
    the list. The question is only why Marked isn't rendering it as such.
    Could you do me a favor and try adding an extra line _before_ the first
    list item? The other thing you could try is switching processors in
    Marked (between Discount and MultiMarkdown) to see if one or the other
    gets it right with the Ulysses markup.

    I just thought of one other thing. When you do the Quick Preview in
    Ulysses, are you making sure you're sending Markdown and not HTML?

    -Brett

  7. 7 Posted by D S on 01 Jun, 2015 10:16 PM

    D S's Avatar

    Hi Brett,

    OK, adding the line break BEFORE the first list item seemed to fix things
    (mostly).

    Here is the output with Ulysses preview on the left, Marked on the right
    (marked using multi column style):[image: Inline image 1]

    Here is the output with Marked using the Antique style which renders with
    the problem still. Most of the other Marked styles seemed fine. Again,
    Ulysses preview on the left:
    [image: Inline image 2]

    Also, I was just able to purchase Marked for $9.99, so thank you!

    -Dennis

  8. Support Staff 8 Posted by Brett on 01 Jun, 2015 11:37 PM

    Brett's Avatar

    That's not creating a code block, though, the Antique style just indents
    succeeding paragraphs in list items intentionally. You can always modify
    that with a custom style or "Additional CSS" setting in Style
    preferences.

    Glad the purchase price changed for you!

    -Brett

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac